Ошибка при работе с SDK 4.3.4.0

Добрый день!
Возникла странная ошибка при переходе на SDK версии 4.3.4.0. Я веду разработку на C# с использованием библиотеки Pkcs11Interop. Выполняю простую последовательность действий:
1. Получаю список подключенных слотов (C_GetSlotList);
2. Получаю для выбранного слота (подключен Рутокен ЭЦП 2) расширенную информацию о токене (C_EX_GetTokenInfoExtended) - "аварийное" завершение процесса при котором не удается даже отловить ошибку. Пробую получить информацию о токене (C_GetTokenInfo) и аналогичный результат. При этом информацию о слоте могу получить. В панеле управления Рутокен информация о токене видна. В событиях журнала Windows никакой информации о падении (ошибках) нет. Если откатиться на версию драйверов 4.3.2, то такой ошибки не возникает.

Re: Ошибка при работе с SDK 4.3.4.0

Добрый день, Mikhail.

Спасибо за сообщение о проблеме. Проверим.

Re: Ошибка при работе с SDK 4.3.4.0

Добрый день, Mikhail.

Пока не удалось воспроизвести Вашу проблему.
Проблема воспроизводится на наших примерах? В Standard.Info есть вызов C_GetTokenInfo.
Посмотрите версию rtPKCS11ECP.dll, на которой происходит падение. Скорее всего вы используете библиотеку из C:\Windows\System32

Re: Ошибка при работе с SDK 4.3.4.0

Добрый день, Владимир Салыкин!

1. Используются библиотеки из C:\Windows\SysWOW64. Сейчас используются библиотеки с драйверами версии 4.3.2.0:
- rtPKCS11.dll. Версия файла: 4.2.5.0. Версия продукта: 4.2.05.0000.
- rtpkcs11ecp.dll. Версия файла: 1.5.3.0. Версия продукта: 1.5.3.0

2. Пробовал обновить библиотеки поставляемые с указанной версией драйверов:
- rtPKCS11.dll. Версия файла: 4.3.2.0. Версия продукта: 4.3.02.0000.
- rtpkcs11ecp.dll. Версия файла: 1.8.0.0. Версия продукта: 1.8.0.0
То код также работает без ошибок. Обновляю драйвера до версии 4.3.4.0. При использовании вышеуказанных библиотек возникает "неизвестная" ошибка.

3. Обновляю библиотеки поставляемые с драйверами версии 4.3.4.0:
- rtPKCS11.dll. Версия файла: 4.3.4.0. Версия продукта: 4.3.04.0000.
- rtpkcs11ecp.dll. Версия файла: 1.8.2.0. Версия продукта: 1.8.2.0
И... Все заработало.

Видимо эти версии немного несовместимы между собой, т.к. в ситуации 1 старые библиотеки работали с новыми драйверами и наоборот. А если использовать библиотеки из версии 4.3.4.0 с предыдущей, то возникает такая же ошибка. В итоге удалось разобраться с ошибкой. Спасибо за помощь! :)