Не запускается плагин в Мазиле

Мазила 52.0.1 при входе в банк появляется сообщение "плагин не установлен или отключен". В Интернет эксплорере все работает. Переустановка плагина и браузера ни чего не дало.

Re: Не запускается плагин в Мазиле

Здравствуйте, dik-kid!

Данная проблема возникает из-за того, что Mozilla Firefox с 52 версии уже не поддерживает NPAPI.
В данный момент нашими разработчиками ведутся работы по решению данной проблемы и ближайшее время мы постараемся выпустить обновленный плагин Рутокен для Firefox.

Пока же можем посоветовать откатиться на версию ниже 52-й.
Или установить Firefox 52 ESR версию отсюда - Будет поддерживаться до мая 2018.
Данный способ может не сработать в последующих версиях. В строке поиска Firefox набрать about:config. Появится предупреждение о возможных последствиях самостоятельного изменения настроек, здесь выбрать "Принимаю риск". В появившемся списке параметров нажать правую кнопку мыши и выбрать во всплывающем меню Создать->Логическое (New->Boolean). Появится окно ввода, где следует задать параметр plugin.load_flash_only и нажать ОК. Далее выбрать в списке значение false и снова нажать OK. После этих действий следует перезапустить Firefox.

(2017-03-23 11:44:53 отредактировано dik-kid)

Re: Не запускается плагин в Мазиле

спасибо.

Все заработало

(2017-05-03 17:02:32 отредактировано artony-msk)

Re: Не запускается плагин в Мазиле

Установил Рутокен Плагин версии 2.8.9.0, про который в пресс-релизе компании "Актив" (https://www.rutoken.ru/press-center/new … 04-06.html) сказано, что он поддерживает Firefox через Native Messaging.
С установленным плагином проверил работу в Рутокен Демобанк (http://demobank.rutoken.ru/). Демоплощадка сообщает "Уважаемый клиент! Установите Рутокен Плагин". Пробовал в ОС Windows 10 и в macOS Sierra. Одинаковая ошибка. Демопрощадка установить web extention не предлагала. В магазине дополнений Mozilla похожего как в Chrome "Адаптер Рутокен Плагин" также не нашел.

Подскажите, как обеспечить работу с плагином в Firefox без необходимости отключать настройку plugin.load_flash_only?

(2017-05-04 12:41:28 отредактировано Алексей Лазарев)

Re: Не запускается плагин в Мазиле

Добрый день,
возможно, по каким-то причинам не активировался Rutoken Plugin Adapter. После установки плагина и перезапуска браузера должно выскочить предупреждение.


На странице с предупреждением нужно включить галку "Разрешить его установку" и нажать кнопку "Продолжить".

Если по каким-то причинам предупреждение не было показано, то нужно включить адаптер вручную.

С уважением, Алексей Лазарев

(2017-05-10 11:11:28 отредактировано Вадим Шушляков)

Re: Не запускается плагин в Мазиле

Добрый день.

Mozilla Firefox 53.0.2, Windows 10.
После переустановки плагина выскочило предупреждение, в настройках плагин включен.
При попытке зайти в http://demobank.rutoken.ru выходит сообщение с просьбой установить плагин,
В веб-консоли предупреждение:

Couldn't connect to Rutoken native messaging host: Host disconnected  demobank.rutoken.ru:1508:5

http://forum.rutoken.ru/uploads/transfer/users/11000/10684/tmp/thumb/p1bfomip9e1oj91k397aa7ek1fcv1.png
В Google Chrome работает.

Re: Не запускается плагин в Мазиле

В Firefox для Windows плагин заработал. Предупреждение об установке Rutoken Plugin Adapter возникло после перезапуска браузера. После установки адаптера плагин на демостранице заработал.

В Firefox для macOS предупреждение об установке Rutoken Plugin Adapter не появляется. И на macOS после установки плагина из RutokenPlugin.pkg даже не находится файл rutoken_plugin_adapter.xpi.

Если скопировать файл rutoken_plugin_adapter.xpi вручную на macOS с Windows (взят из папки C:\Users\...\AppData\Roaming\Aktiv Co\CryptoPlugin\2.8.9.0.), то в macOS удается установить Rutoken Plugin Adapter. Но после этого демостраница все равно не видит в Firefox установленного плагина и предлагает его скачать. Если попробовать обратиться к демостранице в Safari, то там браузер плагин видит.

Re: Не запускается плагин в Мазиле

Добрый день.
Firefox 53 не будет работать через Native Messaging Host под Mаc OS. Используйте версию до 52 либо включите NPAPI в браузере описанным выше способом.

С уважением, Алексей Лазарев

Re: Не запускается плагин в Мазиле

Вадим, а какая разрядность у вашего Firefox? Для 64-й был выпущен фикс. Попробуйте еще раз скачать версию с нашего сайта.

С уважением, Алексей Лазарев